[Astuce] Désactiver cups dans samba


  • Prédateur

    Utilisant samba sans CUPS avec mon Raspberry, j’ai récupérer une erreur récurrente :

    less /var/log/samba/log.smbd
    smbd[5484]: Unable to connect to CUPS server localhost:631 - Connexion refusée
    smbd[5453]: printing/print_cups.c:487(cups_async_callback)
    smbd[5453]: failed to retrieve printer list: NT_STATUS_UNSUCCESSFUL
    

    Ce log indique tout simplement que samba ne trouve pas d’imprimante, il faut donc renseigner samba pour éviter ces logs.

    Ouvrez le fichier conf de samba :

    nano /etc/samba/smb.conf:
    

    Et rajoutez à la fin:

    printing = bsd
    printcap name = /dev/null
    load printers = no
    disable spoolss = yes
    

    Redémarrez samba :

    /etc/init.d/smbd restart
    

    ou

    service samba restart
    

    Et le tour est joué, vous n’avez plus d’erreur dans vos logs ;)


Se connecter pour répondre
 

Il semble que votre connexion ait été perdue, veuillez patienter pendant que nous vous re-connectons.